1.38开发更新

问候!

与我们先前针对1.37版游戏的开发更新一样,我们很高兴地宣布针对1.38版游戏的开发更新。

随着7月14日发布《美国卡车模拟器1.38》和7月21日发布《欧洲卡车模拟器2 1.38》,社区一直在紧张地等待着TruckersMP对最新版本的支持已有一个月了。

尽管我们的支持尚未准备就绪,但我们希望弄清当前的进展,并解释为什么要花费大量的时间。

尽管从表面上看,1.38中似乎没有太多更改可能会延迟我们的进度,但SCS Software已将其推向最新版本的幕后仍有很多更改。

FMOD仍然是影响多人游戏更新的主要因素,因为它们会带来进一步的后端更改,以及在其他玩家附近出现的已知“缺失声音”错误。

为了回答一些受欢迎的问题,我们在下面列出了我们的答案。当然,如果您还有其他疑问,欢迎您在我们的论坛主题上发布。我们将在接下来的几天中监控该主题,并尽快对其进行答复。


预计何时发布1.38的多人支持?

我们目前预计将在8月底/ 9月初发布。我们知道这比大多数人希望的要晚,但是请放心,此更新是我们开发人员的第一要务。

为什么这些更新需要这么长时间?

目前,只有首席开发人员“ mwl4”拥有知识,技能和工具来准备从1.37到1.38的移植。除了致力于更新之外,他在现实世界中也有自己的承诺。

整个团队都竭尽所能为他提供支持,但我们仅限于次要任务。

如果您对mwl4必须移植我们的多人游戏mod以支持最新版本的过程感到好奇,请在这里查看他的视频:[开发视频]将ETS2MP移植到1.14补丁。尽管五年多以前,它仍使我们对开发mod的复杂性含糊不清。

我如何了解有关1.38多人游戏支持的最新信息?

我们将通过定期更新我们的社交媒体渠道和信息来确保您了解情况。

您可以在下面查看它们:

TruckersMP新闻 开发公告(论坛) 不和谐 推特 Instagram的 脸书

我已经更新到1.38,如何在多人服务器上播放?

由于多人游戏尚不支持1.38版本,因此您需要降级游戏版本。

我们在此处提供了有关如何将游戏降级到1.37的指南:如何降级

您也可以在此处查看有关如何降级的视频指南:如何:降级您的游戏

是否支持ProMods 2.46?

ProMods 2.46也不兼容游戏版本1.38。在发布其1.38兼容性更新并在多人游戏上进行测试之前,我们的ProMods多人游戏服务器将不可用。

是否支持“爱达荷州” DLC?

新的爱达荷州DLC将与1.38多人游戏更新版本一起受支持。

喇叭声音错误会在此更新中修复吗?

这是开发人员正在解决的持续问题。这是由新的声音引擎(FMOD)对同时播放的声音的限制引起的。

由于FMOD引入的复杂性,因此无法在1.38多人游戏更新中及时解决。我们正在积极寻求一种绕过FMOD限制的解决方法,但这是一项极其复杂的任务。


到此,我们结束了针对1.38多人游戏的开发更新。

我们了解您对多人支持1.38会花费一些时间而感到沮丧。为了确保我们能够尽快支持最新版本,每天都会花费很多精力进行更新。

不幸的是,1.37和1.38在后端代码中引入了许多复杂的问题,这意味着我们的开发人员被迫花费大量额外的时间来解决它们,才能发布更新。

感谢您的耐心和理解!谢谢。

-TruckersMP团队


关注微信公众号『SK车队』

第一时间了解最新车队动态
关注我们不迷路~


相关文章

发表评论

邮箱地址不会被公开。 必填项已用*标注